Users may be experiencing Payerpath issues.

Incident Report for Veradigm Payerpath

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 12:31 EST

Investigating

We are aware of an issue impacting Veradigm Payerpath. We are working to resolve the issue as quickly as possible.
Posted Dec 09, 2025 - 14:34 EST
This incident affected: Payerpath.